Logo AND Algorithmique Numérique Distribuée

Public GIT Repository
ignore more cruft
[simgrid.git] / CMakeLists.txt
index 985bd6d..3094852 100644 (file)
@@ -1,4 +1,6 @@
 cmake_minimum_required(VERSION 2.6)
+# Java requires 2.8.6
+message(STATUS "Cmake version ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}")
 
 project(SimGrid C CXX)
 
@@ -13,51 +15,57 @@ endif()
 
 ## 
 ## Check the C/C++ standard that we need
-##   See also tools/cmake/Flags.cmake that sets our paranoid warning flags
-INCLUDE(CheckCCompilerFlag)
-CHECK_C_COMPILER_FLAG(-fstack-cleaner HAVE_C_STACK_CLEANER)
-
-## Request full debugging flags
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g3")
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g3")
-set(CMAKE_Fortran_FLAGS "${CMAKE_Fortran_FLAGS} -g")
-
-if (CMAKE_COMPILER_IS_GNUCC)
-  if (COMPILER_CXX_VERSION_MAJOR_MINOR STRLESS "4.7")
-    message(FATAL_ERROR
-            "SimGrid needs at least g++ version 4.7 to compile "
-           "(c++11 support of previous versions is too limited).")
+##   See also tools/cmake/GCCFlags.cmake that sets our paranoid warning flags
+if (MSVC)
+  message("-- You are compiling SimGrid with MicroSoft Visual C. Good luck.")
+
+  set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D_SCL_SECURE_NO_WARNINGS")
+  set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D_SCL_SECURE_NO_WARNINGS")
+else() # gcc or clang
+  INCLUDE(CheckCCompilerFlag)
+  CHECK_C_COMPILER_FLAG(-fstack-cleaner HAVE_C_STACK_CLEANER)
+
+  ## Request full debugging flags
+  set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g3")
+  set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g3")
+  set(CMAKE_Fortran_FLAGS "${CMAKE_Fortran_FLAGS} -g")
+
+  if (CMAKE_COMPILER_IS_GNUCC)
+    if (COMPILER_CXX_VERSION_MAJOR_MINOR STRLESS "4.7")
+      message(FATAL_ERROR
+              "SimGrid needs at least g++ version 4.7 to compile "
+             "(c++11 support of previous versions is too limited).")
+    endif()
   endif()
-endif()
-
-## We need a decent support of the c++11 standard
-include(CheckCXXCompilerFlag)
-CHECK_CXX_COMPILER_FLAG("-std=gnu++11" COMPILER_SUPPORTS_CXX11)
-if(COMPILER_SUPPORTS_CXX11)
-  set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++11")
-else() 
-  message(FATAL_ERROR 
-          "The compiler ${CMAKE_CXX_COMPILER} has no C++11 support. "
-          "Please use a decent C++ compiler.")
-endif()
 
-### And we need C11 standard, too
-include(CheckCCompilerFlag)
-CHECK_C_COMPILER_FLAG("-std=gnu11" COMPILER_SUPPORTS_C11)
-if(COMPILER_SUPPORTS_C11)
-  set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu11")
-else()
-  message(FATAL_ERROR 
-          "The compiler ${CMAKE_C_COMPILER} has no C11 support. "
-          "Please use a decent C compiler "
-          "(note that c++11 support of ${CMAKE_CXX_COMPILER} seems ok).")
-endif()
-if(APPLE AND ("4.6" GREATER COMPILER_C_VERSION_MAJOR_MINOR))
-    ### gcc 4.[1-5] cannot compile ucontext on OSX
-    message(STATUS "Ucontext can't be used with this version of gcc (must be greater than 4.5)")
-    set(HAVE_UCONTEXT_H 0)
-endif()
+  ## We need a decent support of the c++11 standard
+  include(CheckCXXCompilerFlag)
+  CHECK_CXX_COMPILER_FLAG("-std=gnu++11" COMPILER_SUPPORTS_CXX11)
+  if(COMPILER_SUPPORTS_CXX11)
+    set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++11")
+  else() 
+    message(FATAL_ERROR 
+            "The compiler ${CMAKE_CXX_COMPILER} has no C++11 support. "
+            "Please use a decent C++ compiler.")
+  endif()
 
+  ### And we need C11 standard, too
+  include(CheckCCompilerFlag)
+  CHECK_C_COMPILER_FLAG("-std=gnu11" COMPILER_SUPPORTS_C11)
+  if(COMPILER_SUPPORTS_C11)
+    set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu11")
+  else()
+    message(FATAL_ERROR 
+            "The compiler ${CMAKE_C_COMPILER} has no C11 support. "
+            "Please use a decent C compiler "
+            "(note that c++11 support of ${CMAKE_CXX_COMPILER} seems ok).")
+  endif()
+  if(APPLE AND ("4.6" GREATER COMPILER_C_VERSION_MAJOR_MINOR))
+      ### gcc 4.[1-5] cannot compile ucontext on OSX
+      message(STATUS "Ucontext can't be used with this version of gcc (must be greater than 4.5)")
+      set(HAVE_UCONTEXT_H 0)
+  endif()
+endif() # NOT MSVC
 
 ### SMPI vs. Fortran
 if ((NOT DEFINED enable_smpi OR enable_smpi) AND NOT APPLE) # smpi is enabled by default
@@ -89,7 +97,7 @@ endif()
 #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
 
 set(SIMGRID_VERSION_MAJOR "3")
-set(SIMGRID_VERSION_MINOR "12")
+set(SIMGRID_VERSION_MINOR "13")
 set(SIMGRID_VERSION_PATCH "0")
 set(SIMGRID_VERSION_EXTRA "-devel") # Extra words to add to version string (e.g. -rc1)
 
@@ -133,11 +141,6 @@ endif()
 exec_program("${CMAKE_LINKER} --version" OUTPUT_VARIABLE "LINKER_VERSION")
 string(REGEX MATCH "[0-9].[0-9]*" LINKER_VERSION "${LINKER_VERSION}")
 
-string(REGEX MATCH "cl.exe" VBC "${CMAKE_C_COMPILER}")
-if(VBC)
-  message("VB is not yet supported by Simgrid. Proceed with extrem caution")
-endif()
-
 ### Find programs and paths
 FIND_PROGRAM(GCOV_PATH gcov)
 include(FindPerl)
@@ -166,7 +169,6 @@ set(INCLUDES
 if(WIN32)
   set(INCLUDES ${INCLUDES} ${CMAKE_HOME_DIRECTORY}/include/xbt ${CMAKE_HOME_DIRECTORY}/src/xbt) #for win32_ucontext.[ch]
 endif()
-set(CMAKE_SOURCE_DIR ${PROJECT_SOURCE_DIRECTORY})
 
 if(NOT CMAKE_CROSSCOMPILING AND EXISTS /usr/include/)
   set(INCLUDES ${INCLUDES} /usr/include/)
@@ -174,7 +176,11 @@ endif()
 
 ### Check 32bits or 64bits
 INCLUDE (CheckTypeSize)
+CHECK_TYPE_SIZE("int" SIZEOF_INT)
+CHECK_TYPE_SIZE("long" SIZEOF_LONG)
+CHECK_TYPE_SIZE("long long" SIZEOF_LONGLONG)
 CHECK_TYPE_SIZE("void*" SIZEOF_VOIDSTAR)
+message ("   Data model: (int)=${SIZEOF_INT} (long)=${SIZEOF_LONG} (long long)=${SIZEOF_LONGLONG} (void*)=${SIZEOF_VOIDSTAR}")
 IF(SIZEOF_VOIDSTAR EQUAL 4)
   SET(ARCH_32_BITS 1)
 ELSE()
@@ -203,8 +209,6 @@ if(WIN32)
     if(COMPILER_C_MINOR_VERSION)
       # set(__GNUC_MINOR__ ${COMPILER_C_MINOR_VERSION})
     endif()
-  else()
-    message("You REALLY should use MinGW to compile SimGrid on Windows!")
   endif()
 
   set(NSIS_WIN_VERSION $ENV{PROCESSOR_ARCHITEW6432})
@@ -245,8 +249,10 @@ include(${CMAKE_HOME_DIRECTORY}/tools/cmake/DefinePackages.cmake)
 include(${CMAKE_HOME_DIRECTORY}/tools/cmake/MaintainerMode.cmake)
 include(${CMAKE_HOME_DIRECTORY}/tools/cmake/UnitTesting.cmake)
 
-### Setup gcc flags
-include(${CMAKE_HOME_DIRECTORY}/tools/cmake/Flags.cmake)
+### Setup gcc & clang flags
+if (NOT MSVC)
+  include(${CMAKE_HOME_DIRECTORY}/tools/cmake/GCCFlags.cmake)
+endif()
 
 ### Make Libs
 if(NOT WIN32)
@@ -255,28 +261,40 @@ else()
   include(${CMAKE_HOME_DIRECTORY}/tools/cmake/MakeLibWin.cmake)
 endif()
 
-### Make Exes
-include(${CMAKE_HOME_DIRECTORY}/tools/cmake/MakeExe.cmake)
+if(enable_java)
+  include(${CMAKE_HOME_DIRECTORY}/tools/cmake/Java.cmake)
+endif()
 
 ### Make tests
 if(enable_memcheck_xml)
   set(enable_memcheck true)
 endif()
 
-include(${CMAKE_HOME_DIRECTORY}/tools/cmake/AddTests.cmake)
+INCLUDE(CTest)
+ENABLE_TESTING()
+include(${CMAKE_HOME_DIRECTORY}/tools/cmake/Tests.cmake)
 include(${CMAKE_HOME_DIRECTORY}/tools/cmake/CTestConfig.cmake)
 
+### Define subdirectories
+include(${CMAKE_HOME_DIRECTORY}/tools/cmake/MakeExe.cmake)
+
 ### Setup the distrib
 include(${CMAKE_HOME_DIRECTORY}/tools/cmake/Distrib.cmake)
 
-### Pipol compilation
-include(${CMAKE_HOME_DIRECTORY}/tools/cmake/Pipol.cmake)
-
-### Build the doc
+### Build the doc (Windows downloads the doc instead of regenerating)
+#
 if(NOT WIN32)
-  include(${CMAKE_HOME_DIRECTORY}/tools/cmake/GenerateDoc.cmake)
+  include(${CMAKE_HOME_DIRECTORY}/tools/cmake/Documentation.cmake)
 else()
-  include(${CMAKE_HOME_DIRECTORY}/tools/cmake/GenerateDocWin.cmake)
+  find_program(WGET_PROGRAM  NAMES wget)
+  message(STATUS "wget: ${WGET_PROGRAM}")
+  if(WGET_PROGRAM)
+    ADD_CUSTOM_TARGET(simgrid_documentation
+      COMMENT "Downloading the SimGrid documentation..."
+      COMMAND ${WGET_PROGRAM} -r -np -nH -nd http://simgrid.gforge.inria.fr/simgrid/${release_version}/doc/
+      WORKING_DIRECTORY ${CMAKE_HOME_DIRECTORY}/doc/html
+    )
+  endif()
 endif()
 
 ### Print ARGS