Logo AND Algorithmique Numérique Distribuée

Public GIT Repository
Sonar: have a single return.
[simgrid.git] / FindSimGrid.cmake
index 4bf7a04..dd035e2 100644 (file)
-#IF YOU HAVE INSTALL SIMGRID IN A SPECIAL DIRECTORY
-#YOU CAN SPECIFY SIMGRID_ROOT OR GRAS_ROOT
-
-find_library(SIMGRID_LIB
-    NAME simgrid
-    HINTS
-       $ENV{SIMGRID_ROOT}
-    PATH_SUFFIXES lib
+# CMake find module to search for the SimGrid library. 
+
+# Copyright (c) 2016-2018. The SimGrid Team.
+#
+# This file is free software; you can redistribute it and/or modify it
+# under the terms of the license (GNU LGPL) which comes with this package.
+
+#
+# USERS OF PROGRAMS USING SIMGRID
+# -------------------------------
+#
+# If cmake does not find this file, add its path to CMAKE_PREFIX_PATH:
+#    CMAKE_PREFIX_PATH="/path/to/FindSimGrid.cmake:$CMAKE_PREFIX_PATH"  cmake .
+#
+# If this file does not find SimGrid, define SimGrid_PATH:
+#    SimGrid_PATH=/path/to/simgrid  cmake .
+
+#
+# DEVELOPERS OF PROGRAMS USING SIMGRID
+# ------------------------------------
+#
+#  1. Include this file in your own CMakeLists.txt
+#     Either by copying it in your tree, or (recommended) by using the
+#     version automatically installed by SimGrid.
+#    
+#  2. Afterward, if you have CMake >= 2.8.12, this will define a
+#     target called 'SimGrid::Simgrid'. Use it as:
+#       target_link_libraries(your-simulator SimGrid::SimGrid)
+#
+#    With older CMake (< 2.8.12), it simply defines several variables:
+#       SimGrid_INCLUDE_DIR - the SimGrid include directories
+#       SimGrid_LIBRARY - link your simulator against it to use SimGrid
+#    Use as:
+#      include_directories("${SimGrid_INCLUDE_DIR}" SYSTEM)
+#      target_link_libraries(your-simulator ${SimGrid_LIBRARY})
+#
+#  In both cases, it also define a SimGrid_VERSION macro, that you
+#    can use to deal with API evolutions as follows:
+#
+#    #if SimGrid_VERSION < 31800
+#      (code to use if the installed version is lower than v3.18)
+#    #elif SimGrid_VERSION < 31900
+#      (code to use if we are using SimGrid v3.18.x)
+#    #else
+#      (code to use with SimGrid v3.19+)
+#    #endif
+
+# 
+# IMPROVING THIS FILE
+# -------------------
+#  - Use automatic SimGridConfig.cmake creation via export/install(EXPORT in main CMakeLists.txt:
+#    https://cliutils.gitlab.io/modern-cmake/chapters/exporting.html
+#    https://cmake.org/Wiki/CMake/Tutorials/How_to_create_a_ProjectConfig.cmake_file
+#    https://github.com/boostcon/cppnow_presentations_2017/blob/master/05-19-2017_friday/effective_cmake__daniel_pfeifer__cppnow_05-19-2017.pdf
+
+cmake_minimum_required(VERSION 2.8)
+
+find_path(SimGrid_INCLUDE_DIR
+  NAMES simgrid_config.h
+  PATHS ${SimGrid_PATH}/include /opt/simgrid/include
+)
+find_library(SimGrid_LIBRARY
+  NAMES simgrid
+  PATHS ${SimGrid_PATH}/lib /opt/simgrid/lib
 )
+mark_as_advanced(SimGrid_INCLUDE_DIR)
+mark_as_advanced(SimGrid_LIBRARY)
+
+if (SimGrid_INCLUDE_DIR)
+  set(SimGrid_VERSION_REGEX "^#define SIMGRID_VERSION_(MAJOR|MINOR|PATCH) ([0-9]+)$")
+  file(STRINGS "${SimGrid_INCLUDE_DIR}/simgrid_config.h" SimGrid_VERSION_STRING REGEX ${SimGrid_VERSION_REGEX})
+  set(SimGrid_VERSION "")
 
-find_path(SIMGRID_INCLUDES msg/msg.h
-    HINTS
-       $ENV{SIMGRID_ROOT}
-    PATH_SUFFIXES include
+  # Concat the matches to MAJOR.MINOR.PATCH assuming they appear in this order
+  foreach(match ${SimGrid_VERSION_STRING})
+    if(SimGrid_VERSION)
+      set(SimGrid_VERSION "${SimGrid_VERSION}.")
+    endif()
+    string(REGEX REPLACE ${SimGrid_VERSION_REGEX} "${SimGrid_VERSION}\\2" SimGrid_VERSION ${match})
+    set(SimGrid_VERSION_${CMAKE_MATCH_1} ${CMAKE_MATCH_2})
+  endforeach()
+  unset(SimGrid_VERSION_STRING)
+  unset(SimGrid_VERSION_REGEX)  
+endif ()
+
+include(FindPackageHandleStandardArgs)
+find_package_handle_standard_args(SimGrid
+  FOUND_VAR SimGrid_FOUND
+  REQUIRED_VARS SimGrid_INCLUDE_DIR SimGrid_LIBRARY
+  VERSION_VAR SimGrid_VERSION
 )
 
-message(STATUS "Looking for lib SimGrid")
-if(SIMGRID_LIB)
-  message(STATUS "Looking for lib SimGrid - found")
-  if(CMAKE_CACHE_MAJOR_VERSION EQUAL "2" AND CMAKE_CACHE_MINOR_VERSION GREATER "7") #need cmake version 2.8
-         get_filename_component(simgrid_version ${SIMGRID_LIB} REALPATH)
-         string(REPLACE "${SIMGRID_LIB}." "" simgrid_version "${simgrid_version}")
-         string(REGEX MATCH "^[0-9]" SIMGRID_MAJOR_VERSION "${simgrid_version}")
-         string(REGEX MATCH "^[0-9].[0-9]" SIMGRID_MINOR_VERSION "${simgrid_version}")
-         string(REGEX MATCH "^[0-9].[0-9].[0-9]" SIMGRID_PATCH_VERSION "${simgrid_version}")
-         string(REGEX REPLACE "^${SIMGRID_MINOR_VERSION}." "" SIMGRID_PATCH_VERSION "${SIMGRID_PATCH_VERSION}") 
-         string(REGEX REPLACE "^${SIMGRID_MAJOR_VERSION}." "" SIMGRID_MINOR_VERSION "${SIMGRID_MINOR_VERSION}")
-         message(STATUS "Simgrid version : ${SIMGRID_MAJOR_VERSION}.${SIMGRID_MINOR_VERSION}")
-  endif(CMAKE_CACHE_MAJOR_VERSION EQUAL "2" AND CMAKE_CACHE_MINOR_VERSION GREATER "7")
-else(SIMGRID_LIB)
-  message(STATUS "Looking for lib SimGrid - not found")
-endif(SIMGRID_LIB)
-
-message(STATUS "Looking for msg.h")
-if(SIMGRID_INCLUDES)
-  message(STATUS "Looking for msg.h - found")
-else(SIMGRID_INCLUDES)
-  message(STATUS "Looking for msg.h - not found")
-endif(SIMGRID_INCLUDES)
-
-if(SIMGRID_LIB AND SIMGRID_INCLUDES)
-else(SIMGRID_LIB AND SIMGRID_INCLUDES)
-    message(FATAL_ERROR "Unable to find both the library and the include files. Setting the environment variable SIMGRID_ROOT may help.")
-endif(SIMGRID_LIB AND SIMGRID_INCLUDES)
\ No newline at end of file
+if (SimGrid_FOUND AND NOT CMAKE_VERSION VERSION_LESS 2.8.12)
+  add_library(SimGrid::SimGrid SHARED IMPORTED)
+  set_target_properties(SimGrid::SimGrid PROPERTIES
+    INTERFACE_SYSTEM_INCLUDE_DIRECTORIES ${SimGrid_INCLUDE_DIR}
+    INTERFACE_COMPILE_FEATURES cxx_alias_templates
+    IMPORTED_LOCATION ${SimGrid_LIBRARY}
+  )
+  # We need C++11, so check for it just in case the user removed it since compiling SimGrid
+  if (NOT CMAKE_VERSION VERSION_LESS 3.8)
+    # 3.8+ allows us to simply require C++11 (or higher)
+    set_property(TARGET SimGrid::SimGrid PROPERTY INTERFACE_COMPILE_FEATURES cxx_std_11)
+  elseif (NOT CMAKE_VERSION VERSION_LESS 3.1)
+    # 3.1+ is similar but for certain features. We pick just one
+    set_property(TARGET SimGrid::SimGrid PROPERTY INTERFACE_COMPILE_FEATURES cxx_alias_templates)
+  else ()
+    # Old CMake can't do much. Just check the CXX_FLAGS and inform the user when a C++11 feature does not work
+    include(CheckCXXSourceCompiles)
+    set(CMAKE_REQUIRED_FLAGS "${CMAKE_CXX_FLAGS}")
+    check_cxx_source_compiles("using Foo = int; int main(){}" _SIMGRID_CXX11_ENABLED)
+    if (NOT _SIMGRID_CXX11_ENABLED)
+        message(WARNING "C++11 is required to use SimGrid. Enable it with e.g. -std=c++11")
+    endif ()
+    unset(_SIMGRID_CXX11_ENABLED CACHE)
+  endif ()
+endif ()
+