Logo AND Algorithmique Numérique Distribuée

Public GIT Repository
docker: fix the build of images for simgrid stable
[simgrid.git] / CMakeLists.txt
index a90d52f..34d5caa 100644 (file)
@@ -91,7 +91,7 @@ endif()
 #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
 
 set(SIMGRID_VERSION_MAJOR "3")
-set(SIMGRID_VERSION_MINOR "21")
+set(SIMGRID_VERSION_MINOR "22")
 set(SIMGRID_VERSION_PATCH "90")
 set(SIMGRID_VERSION_EXTRA "-DEVEL") # Extra words to add to version string (e.g. -rc1)
 
@@ -254,26 +254,30 @@ endif()
 set(_Boost_STACKTRACE_HEADERS           "boost/stacktrace.hpp")
 set(_Boost_STACKTRACE_BACKTRACE_HEADERS "boost/stacktrace.hpp")
 
-find_package(Boost 1.59 COMPONENTS context stacktrace_backtrace)
-set(Boost_FOUND 1) # These components are optionals
-message(STATUS "Mandatory components found. SimGrid is compilable.")
-message(STATUS "Looking for optional Boost components:")
-
-if (Boost_STACKTRACE_BACKTRACE_FOUND)
-  message (STATUS "  stacktrace: found. Activating human-readable stack traces.")
-  set(HAVE_BOOST_STACKTRACE 1)
-  set(SIMGRID_DEP "${SIMGRID_DEP} -lboost_stacktrace_backtrace")
+if(minimal_java) # When we want a minimal jarfile, don't even search for boost optional components
+  message(STATUS "Don't even look for boost optional components, as we build a minimal jar file")
 else()
-  message (STATUS "  stacktrace: MISSING. Install libboost-stacktrace-dev to display the stacktraces.")
-  set(HAVE_BOOST_STACKTRACE 0)
-endif()
+  find_package(Boost 1.59 COMPONENTS context stacktrace_backtrace)
+  set(Boost_FOUND 1) # These components are optionals
+  message(STATUS "Mandatory components found. SimGrid is compilable.")
+  message(STATUS "Looking for optional Boost components:")
+
+  if (Boost_STACKTRACE_BACKTRACE_FOUND)
+    message (STATUS "  stacktrace: found. Activating human-readable stack traces.")
+    set(HAVE_BOOST_STACKTRACE 1)
+    set(SIMGRID_DEP "${SIMGRID_DEP} -lboost_stacktrace_backtrace")
+  else()
+    message (STATUS "  stacktrace: MISSING. Install libboost-stacktrace-dev to display the stacktraces.")
+    set(HAVE_BOOST_STACKTRACE 0)
+  endif()
 
-if(Boost_CONTEXT_FOUND)
-  message (STATUS "  context: found. Activating Boost contexts.")
-  set(HAVE_BOOST_CONTEXTS 1)
-else()
-  message (STATUS "  context: MISSING. Install libboost-context-dev for this optional feature.")
-  set(HAVE_BOOST_CONTEXTS 0)
+  if(Boost_CONTEXT_FOUND)
+    message (STATUS "  context: found. Activating Boost contexts.")
+    set(HAVE_BOOST_CONTEXTS 1)
+  else()
+    message (STATUS "  context: MISSING. Install libboost-context-dev for this optional feature.")
+    set(HAVE_BOOST_CONTEXTS 0)
+  endif()
 endif()
 
 
@@ -352,12 +356,19 @@ else()
   SET(SIMGRID_HAVE_MALLOCATOR 0)
 endif()
 
-include(FindLibunwind)
-if(HAVE_LIBUNWIND)
-  SET(SIMGRID_DEP "${SIMGRID_DEP} ${LIBUNWIND_LIBRARIES}")
-else()
+if (minimal_java)
+  message(STATUS "Don't look for libunwind as we build a minimal jar file.")
   if(enable_model-checking)
-    message(FATAL_ERROR "Please install libunwind-dev libdw-dev libelf-dev libevent-dev if you want to compile the SimGrid model checker.")
+    message(FATAL_ERROR "You cannot enable model-checking and minimal_java at the same time.")
+  endif()
+else()
+  include(FindLibunwind)
+  if(HAVE_LIBUNWIND)
+    SET(SIMGRID_DEP "${SIMGRID_DEP} ${LIBUNWIND_LIBRARIES}")
+  else()
+    if(enable_model-checking)
+      message(FATAL_ERROR "Please install libunwind-dev libdw-dev libelf-dev libevent-dev if you want to compile the SimGrid model checker.")
+    endif()
   endif()
 endif()