Logo AND Algorithmique Numérique Distribuée

Public GIT Repository
enable wait_any and wait_any_for for asynchronous executions
[simgrid.git] / CMakeLists.txt
index 786e63d..50075e0 100644 (file)
@@ -1,9 +1,15 @@
-cmake_minimum_required(VERSION 2.8.8)
+cmake_minimum_required(VERSION 3.5)
 message(STATUS "Cmake version ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION}")
 set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_HOME_DIRECTORY}/tools/cmake/Modules)
 
 project(SimGrid C CXX)
 
+## Save compiler flags preset with environment variables CFLAGS or CXXFLAGS;
+## they will used within smpicc, smpicxx.
+## Do it early so that we get their genuine values. The same will be done later for Fortran.
+set(SMPI_C_FLAGS "${CMAKE_C_FLAGS}")
+set(SMPI_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
+
 #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
 #     Check for the compiler        #
 #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
@@ -15,14 +21,13 @@ endif()
 
 ## 
 ## Check the C/C++ standard that we need
-##   See also tools/cmake/GCCFlags.cmake that sets our paranoid warning flags
+##   See also tools/cmake/Flags.cmake that sets our paranoid warning flags
 INCLUDE(CheckCCompilerFlag)
 CHECK_C_COMPILER_FLAG(-fstack-cleaner HAVE_C_STACK_CLEANER)
 
 ## Request full debugging flags
 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g3")
 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g3")
-set(CMAKE_Fortran_FLAGS "${CMAKE_Fortran_FLAGS} -g")
 
 if (CMAKE_COMPILER_IS_GNUCC)    
   if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS "4.7")
@@ -80,6 +85,10 @@ if ((NOT DEFINED enable_smpi) OR enable_smpi)
       set(SMPI_Fortran_LIBS "")
       set(SMPI_FLANG 1)
     endif()
+    set(SMPI_Fortran_FLAGS "${SMPI_Fortran_FLAGS} ${CMAKE_Fortran_FLAGS}")
+
+    ## Request debugging flags for Fortran too
+    set(CMAKE_Fortran_FLAGS "${CMAKE_Fortran_FLAGS} -g")
 
     set(SMPI_FORTRAN 1)
   endif(CMAKE_Fortran_COMPILER)
@@ -91,11 +100,11 @@ endif()
 #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
 
 set(SIMGRID_VERSION_MAJOR "3")
-set(SIMGRID_VERSION_MINOR "21")
+set(SIMGRID_VERSION_MINOR "22")
 set(SIMGRID_VERSION_PATCH "90")
 set(SIMGRID_VERSION_EXTRA "-DEVEL") # Extra words to add to version string (e.g. -rc1)
 
-set(SIMGRID_VERSION_DATE  "2018") # Year for copyright information
+set(SIMGRID_VERSION_DATE  "2019") # Year for copyright information
 
 if(${SIMGRID_VERSION_PATCH} EQUAL "0")
   set(release_version "${SIMGRID_VERSION_MAJOR}.${SIMGRID_VERSION_MINOR}")
@@ -121,11 +130,6 @@ endif()
 execute_process(COMMAND ${CMAKE_LINKER} -version OUTPUT_VARIABLE LINKER_VERSION ERROR_VARIABLE LINKER_VERSION)
 string(REGEX MATCH "[0-9].[0-9]*" LINKER_VERSION "${LINKER_VERSION}")
 
-### Set the library providing dlopen
-if("${CMAKE_SYSTEM_NAME}" MATCHES "kFreeBSD|Linux")
-  find_library(DL_LIBRARY dl)
-endif()
-
 ### Find programs and paths
 FIND_PROGRAM(GCOV_PATH gcov)
 include(FindPerl)
@@ -139,7 +143,7 @@ set(PythonInterp_FIND_VERSION_COUNT 1)
 set(PythonInterp_FIND_VERSION_MAJOR 3)
 include(FindPythonInterp)
 if(NOT PYTHONINTERP_FOUND)
-  message(FATAL_ERROR "Please install Python (version 3 or higher).")
+  message(FATAL_ERROR "Please install Python (version 3 or higher) to compile SimGrid.")
 endif()
 
 SET(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/lib)
@@ -258,41 +262,47 @@ endif()
 # Usable components: https://www.boost.org/doc/libs/1_65_1/doc/html/stacktrace/configuration_and_build.html
 set(_Boost_STACKTRACE_HEADERS           "boost/stacktrace.hpp")
 set(_Boost_STACKTRACE_BACKTRACE_HEADERS "boost/stacktrace.hpp")
+set(_Boost_STACKTRACE_ADDR2LINE_HEADERS "boost/stacktrace.hpp")
 
-find_package(Boost 1.59 COMPONENTS context stacktrace_backtrace unit_test_framework)
-set(Boost_FOUND 1) # These components are optionals
-message(STATUS "Mandatory components found. SimGrid is compilable.")
-message(STATUS "Looking for optional Boost components:")
-
-if (Boost_STACKTRACE_BACKTRACE_FOUND)
-  message (STATUS "  stacktrace: found. Activating human-readable stack traces.")
-  set(HAVE_BOOST_STACKTRACE 1)
-  set(SIMGRID_DEP "${SIMGRID_DEP} -lboost_stacktrace_backtrace")
+if(minimal_java) # When we want a minimal jarfile, don't even search for boost optional components
+  message(STATUS "Don't even look for boost optional components, as we build a minimal jar file")
 else()
-  message (STATUS "  stacktrace: MISSING. Install libboost-stacktrace-dev to display the stacktraces.")
-  set(HAVE_BOOST_STACKTRACE 0)
-endif()
-
-if(Boost_CONTEXT_FOUND)
-  message (STATUS "  context: found. Activating Boost contexts.")
-  set(HAVE_BOOST_CONTEXTS 1)
-else()
-  message (STATUS "  context: MISSING. Install libboost-context-dev for this optional feature.")
-  set(HAVE_BOOST_CONTEXTS 0)
-endif()
+  find_package(Boost 1.59 COMPONENTS context stacktrace_backtrace stacktrace_addr2line)
+  set(Boost_FOUND 1) # These components are optionals
+  message(STATUS "Mandatory components found. SimGrid is compilable.")
+  message(STATUS "Looking for optional Boost components:")
+
+  if (Boost_STACKTRACE_BACKTRACE_FOUND)
+    message (STATUS "  stacktrace: found the fast 'backtrace' implementation. Activating human-readable stack traces.")
+    set(HAVE_BOOST_STACKTRACE_BACKTRACE 1)
+    set(SIMGRID_DEP "${SIMGRID_DEP} -lboost_stacktrace_backtrace")
+  else()
+    set(HAVE_BOOST_STACKTRACE_BACKTRACE 0)
+    
+    if (Boost_STACKTRACE_ADDR2LINE_FOUND)
+      message (STATUS "  stacktrace: found the slow 'addr2line' implementation. Activating human-readable stack traces.")
+      set(HAVE_BOOST_STACKTRACE_ADDR2LINE 1)
+      set(SIMGRID_DEP "${SIMGRID_DEP} -lboost_stacktrace_addr2line")
+    else()
+      message (STATUS "  stacktrace: MISSING. Install libboost-stacktrace-dev to display the stacktraces.")
+      set(HAVE_BOOST_STACKTRACE_ADDR2LINE 0)
+    endif()
+  endif()
 
-if (Boost_UNIT_TEST_FRAMEWORK_FOUND)
-  message(STATUS  "  unit_test_framework: found. Activating the Boost-based unit tests.")
-else()
-  message(STATUS  "  unit_test_framework: MISSING. Install libboost-test-dev (>= v1.59) to activate the Unit Tests.")
+  if(Boost_CONTEXT_FOUND)
+    message (STATUS "  context: found. Activating Boost contexts.")
+    set(HAVE_BOOST_CONTEXTS 1)
+  else()
+    message (STATUS "  context: MISSING. Install libboost-context-dev for this optional feature.")
+    set(HAVE_BOOST_CONTEXTS 0)
+  endif()
 endif()
 
 
 # Checks for header libraries functions.
 CHECK_LIBRARY_EXISTS(rt      clock_gettime           "" HAVE_POSIX_GETTIME)
-
-set(HAVE_PTHREAD_SETAFFINITY 0)
 CHECK_LIBRARY_EXISTS(pthread pthread_setaffinity_np  "" HAVE_PTHREAD_SETAFFINITY)
+CHECK_INCLUDE_FILE("pthread_np.h" HAVE_PTHREAD_NP_H) # for pthread_setaffinity_np() on FreeBSD
 
 if(CMAKE_SYSTEM_NAME MATCHES "Darwin")
   set(CMAKE_REQUIRED_DEFINITIONS "-D_XOPEN_SOURCE=700 -D_DARWIN_C_SOURCE")
@@ -332,9 +342,9 @@ endif()
 CHECK_INCLUDE_FILE("sys/sendfile.h" HAVE_SENDFILE_H)
 CHECK_FUNCTION_EXISTS(sendfile HAVE_SENDFILE)
 if(HAVE_SENDFILE_H AND HAVE_SENDFILE)
-  set(HAVE_SENDFILE 1)
+  set(SG_HAVE_SENDFILE 1)
 else()
-  set(HAVE_SENDFILE 0)
+  set(SG_HAVE_SENDFILE 0)
 endif()
 
 if(enable_model-checking AND NOT "${CMAKE_SYSTEM}" MATCHES "Linux|FreeBSD")
@@ -364,12 +374,19 @@ else()
   SET(SIMGRID_HAVE_MALLOCATOR 0)
 endif()
 
-include(FindLibunwind)
-if(HAVE_LIBUNWIND)
-  SET(SIMGRID_DEP "${SIMGRID_DEP} ${LIBUNWIND_LIBRARIES}")
-else()
+if (minimal_java)
+  message(STATUS "Don't look for libunwind as we build a minimal jar file.")
   if(enable_model-checking)
-    message(FATAL_ERROR "Please install libunwind-dev libdw-dev libelf-dev libevent-dev if you want to compile the SimGrid model checker.")
+    message(FATAL_ERROR "You cannot enable model-checking and minimal_java at the same time.")
+  endif()
+else()
+  include(FindLibunwind)
+  if(HAVE_LIBUNWIND)
+    SET(SIMGRID_DEP "${SIMGRID_DEP} ${LIBUNWIND_LIBRARIES}")
+  else()
+    if(enable_model-checking)
+      message(FATAL_ERROR "Please install libunwind-dev libdw-dev libelf-dev libevent-dev if you want to compile the SimGrid model checker.")
+    endif()
   endif()
 endif()
 
@@ -397,8 +414,7 @@ endif()
 
 if(enable_smpi)
   SET(HAVE_SMPI 1)
-  if("${CMAKE_SYSTEM}" MATCHES "Darwin|FreeBSD|Linux")
-    SET(USE_LIBUTIL 0)
+  if("${CMAKE_SYSTEM}" MATCHES "Darwin|FreeBSD|Linux|SunOS")
     SET(HAVE_PRIVATIZATION 1)
   else()
     message (STATUS "Warning:  no support for SMPI automatic privatization on this platform")
@@ -409,81 +425,7 @@ else()
 endif()
 
 #--------------------------------------------------------------------------------------------------
-### Initialize of CONTEXT THREADS
-
-set(HAVE_THREAD_CONTEXTS 0)
-if(CMAKE_USE_PTHREADS_INIT)
-  ### Test that we have a way to create semaphores
-
-  set(HAVE_SEM_OPEN 0)
-  CHECK_LIBRARY_EXISTS(pthread sem_open "" HAVE_SEM_OPEN_LIB)
-  if(HAVE_SEM_OPEN_LIB)
-    try_run(semopen_retval semopen_compilable
-            ${CMAKE_BINARY_DIR}
-            ${CMAKE_HOME_DIRECTORY}/tools/cmake/test_prog/prog_sem_open.c
-           LINK_LIBRARIES pthread
-           COMPILE_OUTPUT_VARIABLE semopen_compilmsg
-            RUN_OUTPUT_VARIABLE semopen_runmsg)
-    
-    if(semopen_compilable)
-      if(NOT semopen_retval) # error if not 0
-        message(STATUS "sem_open is compilable and executable")
-       set(HAVE_SEM_OPEN 1)
-      else()
-        message(STATUS "Warning: sem_open seems compilable but not executable")
-        message(STATUS "Compilation output: ${semopen_compilmsg}")
-        message(STATUS "Execution output: ${semopen_runmsg}")
-        message(STATUS "Exit value: ${semopen_retval}")
-      endif()
-    else()
-      message(STATUS "Warning: sem_open not compilable")
-      message(STATUS "Compilation output: ${semopen_compilmsg}")
-    endif()
-    unset(semopen_compilable)
-    unset(semopen_retval)
-    unset(semopen_runmsg)
-    unset(semopen_compilmsg)
-  endif()
-
-  set(HAVE_SEM_INIT 0)  
-  if(NOT APPLE) # OS X El Capitan deprecates this function
-    CHECK_LIBRARY_EXISTS(pthread sem_init "" HAVE_SEM_INIT_LIB)
-  endif()
-  if(HAVE_SEM_INIT_LIB)
-    try_run(seminit_retval seminit_compilable
-            ${CMAKE_BINARY_DIR}
-            ${CMAKE_HOME_DIRECTORY}/tools/cmake/test_prog/prog_sem_init.c
-           LINK_LIBRARIES pthread
-           COMPILE_OUTPUT_VARIABLE seminit_compilmsg
-            RUN_OUTPUT_VARIABLE seminit_runmsg)
-    
-    if(seminit_compilable)
-      if(NOT seminit_retval) # error if not 0
-        message(STATUS "sem_init is compilable and executable")
-       set(HAVE_SEM_INIT 1)
-      else()
-        message(STATUS "Warning: sem_init seems compilable but not executable")
-        message(STATUS "Compilation output: ${seminit_compilmsg}")
-        message(STATUS "Execution output: ${seminit_runmsg}")
-        message(STATUS "Exit value: ${seminit_retval}")
-      endif()
-    else()
-      message(STATUS "Warning: sem_init not compilable")
-      message(STATUS "Compilation output: ${seminit_compilmsg}")
-    endif()
-    unset(seminit_compilable)
-    unset(seminit_retval)
-    unset(seminit_runmsg)
-    unset(seminit_compilmsg)
-  endif()
-
-  if(NOT HAVE_SEM_OPEN AND NOT HAVE_SEM_INIT)
-    message(FATAL_ERROR "Semaphores are not usable (failed to use both sem_open and sem_init), but they are mandatory to threads (you may need to mount /dev).")
-  endif()
-
-  set(HAVE_THREAD_CONTEXTS 1)
-  message(STATUS "Support for thread context factory ok.")
-endif()
+### Check what context backends are available
 
 set(HAVE_UCONTEXT_CONTEXTS 0)
 if(NOT HAVE_UCONTEXT_H)
@@ -548,58 +490,45 @@ file(REMOVE test_stackgrowth)
 ## GIT version check
 ##
 if(EXISTS ${CMAKE_HOME_DIRECTORY}/.git/)
-  execute_process(
-     COMMAND git remote
-     COMMAND head -n 1
-     WORKING_DIRECTORY ${CMAKE_HOME_DIRECTORY}/.git/
-     OUTPUT_VARIABLE remote
+  execute_process(COMMAND git rev-parse --verify --short HEAD
+     WORKING_DIRECTORY ${CMAKE_HOME_DIRECTORY}
+     OUTPUT_VARIABLE GIT_VERSION
      OUTPUT_STRIP_TRAILING_WHITESPACE)
-  #message(STATUS "Git remote: ${remote}")
-  execute_process(COMMAND git config --get remote.${remote}.url
-     WORKING_DIRECTORY ${CMAKE_HOME_DIRECTORY}/.git/
-     OUTPUT_VARIABLE url
-     OUTPUT_STRIP_TRAILING_WHITESPACE)
-  #message(STATUS "Git url: ${url}")
-  if(url)
-    execute_process(COMMAND git --git-dir=${CMAKE_HOME_DIRECTORY}/.git log --pretty=oneline --abbrev-commit -1
-       WORKING_DIRECTORY ${CMAKE_HOME_DIRECTORY}/.git/
-       OUTPUT_VARIABLE GIT_VERSION
-       OUTPUT_STRIP_TRAILING_WHITESPACE)
-    message(STATUS "Git version: ${GIT_VERSION}")
-
-    execute_process(COMMAND git --git-dir=${CMAKE_HOME_DIRECTORY}/.git log -n 1 --pretty=format:%ai .
-       WORKING_DIRECTORY ${CMAKE_HOME_DIRECTORY}/.git/
-       OUTPUT_VARIABLE GIT_DATE 
-       OUTPUT_STRIP_TRAILING_WHITESPACE)
-    message(STATUS "Git date: ${GIT_DATE}")
-    string(REGEX REPLACE " .*" "" GIT_VERSION "${GIT_VERSION}")
-
-    execute_process(COMMAND git --git-dir=${CMAKE_HOME_DIRECTORY}/.git log --pretty=format:%H -1
-       WORKING_DIRECTORY ${CMAKE_HOME_DIRECTORY}/.git/
-       OUTPUT_VARIABLE SIMGRID_GITHASH
-       OUTPUT_STRIP_TRAILING_WHITESPACE)
+  # Check for uncommitted changes
+  execute_process(COMMAND git diff --name-only HEAD
+    WORKING_DIRECTORY ${CMAKE_HOME_DIRECTORY}
+    OUTPUT_VARIABLE files_changed)
+  if(files_changed)
+    set(GIT_VERSION "${GIT_VERSION}-dirty")
   endif()
 elseif(EXISTS ${CMAKE_HOME_DIRECTORY}/.gitversion)
   FILE(STRINGS ${CMAKE_HOME_DIRECTORY}/.gitversion GIT_VERSION)
 else()
   set(GIT_VERSION "none, release version")
 endif()
+message(STATUS "Git version: ${GIT_VERSION}")
 
-### Setup gcc & clang flags
+### Define source packages for Libs
+include(${CMAKE_HOME_DIRECTORY}/tools/cmake/DefinePackages.cmake)
+
+### Setup gcc & clang flags (include after DefinePackage.cmake, and before generating header files)
 if (NOT MSVC)
-  include(${CMAKE_HOME_DIRECTORY}/tools/cmake/GCCFlags.cmake)
+  include(${CMAKE_HOME_DIRECTORY}/tools/cmake/Flags.cmake)
 endif()
 
 ### Generate the required headers and scripts
 #############################################
 
 # Avoid triggering a (full) rebuild by touching the files if they did not really change
-configure_file("${CMAKE_HOME_DIRECTORY}/tools/cmake/src/internal_config.h.in" "${CMAKE_BINARY_DIR}/src/internal_config.h.generated"    @ONLY IMMEDIATE)
-configure_file("${CMAKE_HOME_DIRECTORY}/include/simgrid/config.h.in"          "${CMAKE_BINARY_DIR}/include/simgrid/config.h.generated" @ONLY IMMEDIATE)
+configure_file("${CMAKE_HOME_DIRECTORY}/src/internal_config.h.in"    "${CMAKE_BINARY_DIR}/src/internal_config.h.generated"    @ONLY IMMEDIATE)
+configure_file("${CMAKE_HOME_DIRECTORY}/src/simgrid/version.h.in"    "${CMAKE_BINARY_DIR}/src/simgrid/version.h.generated" @ONLY IMMEDIATE)
+configure_file("${CMAKE_HOME_DIRECTORY}/include/simgrid/config.h.in" "${CMAKE_BINARY_DIR}/include/simgrid/config.h.generated" @ONLY IMMEDIATE)
 execute_process(COMMAND ${CMAKE_COMMAND} -E copy_if_different ${CMAKE_BINARY_DIR}/src/internal_config.h.generated ${CMAKE_BINARY_DIR}/src/internal_config.h)
+execute_process(COMMAND ${CMAKE_COMMAND} -E copy_if_different ${CMAKE_BINARY_DIR}/src/simgrid/version.h.generated ${CMAKE_BINARY_DIR}/src/simgrid/version.h)
 execute_process(COMMAND ${CMAKE_COMMAND} -E copy_if_different ${CMAKE_BINARY_DIR}/include/simgrid/config.h.generated ${CMAKE_BINARY_DIR}/include/simgrid/config.h)
 file(REMOVE ${CMAKE_BINARY_DIR}/src/internal_config.h.generated)
 file(REMOVE ${CMAKE_BINARY_DIR}/include/simgrid/config.h.generated)
+file(REMOVE ${CMAKE_BINARY_DIR}/src/simgrid/version.h.generated)
 
 # We need two versions of the SMPI scripts because they contain the path to the library
 # so, it depends of whether SimGrid is installed, or run from the sources (during the build)
@@ -829,12 +758,10 @@ endif()
 SET_DIRECTORY_PROPERTIES(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES
   "${generated_files_to_clean}")
 
-### Define source packages for Libs
-include(${CMAKE_HOME_DIRECTORY}/tools/cmake/DefinePackages.cmake)
+add_custom_target(tests COMMENT "Recompiling the tests")
 
 ### Build some Maintainer files
 include(${CMAKE_HOME_DIRECTORY}/tools/cmake/MaintainerMode.cmake)
-include(${CMAKE_HOME_DIRECTORY}/tools/cmake/UnitTesting.cmake)
 
 ### Make Libs
 if(NOT WIN32)
@@ -847,6 +774,69 @@ if(enable_java)
   include(${CMAKE_HOME_DIRECTORY}/tools/cmake/Java.cmake)
 endif()
 
+# Python binding (with pybind11)
+################
+# Our usage of pybind11::overload_cast mandates C++14
+if((NOT DEFINED enable_python) OR enable_python)
+  get_property(known_features GLOBAL PROPERTY CMAKE_CXX_KNOWN_FEATURES)
+
+  if("cxx_std_14" IN_LIST known_features)
+
+    if(EXISTS ${CMAKE_HOME_DIRECTORY}/pybind11) # Try to use a local copy of pybind11, if any
+      message(STATUS "Use the internal copy of pybind11 (using C++14).")
+      add_subdirectory(${CMAKE_HOME_DIRECTORY}/pybind11)
+      set(pybind11_FOUND ON)
+
+      set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_HOME_DIRECTORY}/pybind11/tools/)
+      set(Python_ADDITIONAL_VERSIONS 3.7 3.6 3.5 3.4)
+      find_package(PythonLibsNew ${PYBIND11_PYTHON_VERSION} REQUIRED)
+
+    else()
+      find_package(pybind11 2.2.0)
+    endif()
+
+    if(NOT PYTHONLIBS_FOUND)
+      message(STATUS "Python libs not found. Turn pybind11 off.")
+
+      set(pybind11_FOUND OFF)
+    endif()
+
+  else()
+    message(STATUS "No support for C++14 detected, don't even search for pybind11.")
+    set(pybind11_FOUND OFF)
+  endif()
+  unset(known_features)
+endif()
+
+option(enable_python "Whether the Python bindings are activated." ${pybind11_FOUND}) # ON by default if dependencies are met
+
+if("${CMAKE_SYSTEM}" MATCHES "FreeBSD" AND enable_model-checking AND enable_python)
+  message(WARNING "FreeBSD + Model-Checking + Python = too much for now. Disabling python.")
+  set(enable_python FALSE)
+endif()
+
+if(enable_python)
+  if(pybind11_FOUND)
+    message(STATUS "Found pybind11, with C++14.")
+    if(NOT enable_lto)
+      set(pybind11_options NO_EXTRAS)
+    endif()
+    pybind11_add_module(python-bindings src/bindings/python/simgrid_python.cpp ${pybind11_options})
+    target_compile_features(python-bindings PRIVATE cxx_std_14)
+    target_link_libraries(python-bindings PUBLIC simgrid)
+    set_target_properties(python-bindings PROPERTIES
+                          LIBRARY_OUTPUT_NAME simgrid
+                          CXX_VISIBILITY_PRESET "default")
+    add_dependencies(tests python-bindings)
+    set_property(TARGET python-bindings
+                 APPEND PROPERTY INCLUDE_DIRECTORIES "${INTERNAL_INCLUDES}")
+  else()
+    message(FATAL_ERROR "Please install pybind11-dev to build the Python bindings (or disable that option).")
+  endif()
+endif()
+mark_as_advanced(PYBIND11_PYTHON_VERSION)
+mark_as_advanced(pybind11_DIR)
+
 ### Make tests
 if(enable_memcheck_xml)
   set(enable_memcheck true)
@@ -911,6 +901,7 @@ message("                version .............: ${CMAKE_CXX_COMPILER_VERSION}")
 if(${Java_FOUND})
   message("        Compiler: Javac .............: ${Java_JAVAC_EXECUTABLE}")
   message("                version .............: ${Java_VERSION_STRING}")
+  message("                runtime .............: ${Java_JAVA_EXECUTABLE}")
 endif()
 if(CMAKE_Fortran_COMPILER)
   message("        Compiler: Fortran ...........: ${SMPI_Fortran_COMPILER} (id: ${CMAKE_Fortran_COMPILER_ID})")
@@ -938,6 +929,12 @@ if (${Java_FOUND})
 else()
   message("        Compile Java ................: NO")
 endif()
+if(pybind11_FOUND)
+  message("        Compile Python bindings .....: ${enable_python}")
+  message("          module ....................: ${PYTHON_MODULE_PREFIX}simgrid${PYTHON_MODULE_EXTENSION}")
+else()
+  message("        Compile Python bindings .....: NO (disabled, or pybind11 not found)")
+endif()
 message("        Compile Lua .................: ${SIMGRID_HAVE_LUA}")
 message("        Compile Smpi ................: ${HAVE_SMPI}")
 message("          Smpi fortran ..............: ${SMPI_FORTRAN}")