Logo AND Algorithmique Numérique Distribuée

Public GIT Repository
cmake: better error message
[simgrid.git] / tools / cmake / Modules / FindLuaSimgrid.cmake
index cc27338..2904b98 100644 (file)
@@ -23,7 +23,12 @@ find_path(LUA_INCLUDE_DIR lua.h
 )
 
 find_library(LUA_LIBRARY
-  NAMES lua53 lua5.3 lua-5.3 lua
+  NAMES # I don't want a lua.a
+    lua53.so     lua5.3.so     lua-5.3.so
+    lua53.dynlib lua5.3.dynlib lua-5.3.dynlib
+    lua53.dll    lua5.3.dll    lua-5.3.dll
+    lua.so lua.dynlib lua.dll
+    lua53 lua5.3 lua-5.3 lua
   HINTS
     ENV LUA_HINT
   PATH_SUFFIXES lib
@@ -52,7 +57,6 @@ unset(lua_version_str)
 # Check that we have a sufficient version of Lua
 if(LUA_VERSION_MAJOR EQUAL 5 AND LUA_VERSION_MINOR EQUAL 3)
   set(HAVE_LUA 1)
-    
   include_directories(${LUA_INCLUDE_DIR})
 else()
   message(FATAL_ERROR "Error: Lua version 5.3 is required, but version ${LUA_VERSION_MAJOR}.${LUA_VERSION_MINOR} found instead.")
@@ -60,3 +64,5 @@ endif()
 
 message(STATUS "Lua version: ${LUA_VERSION_MAJOR}.${LUA_VERSION_MINOR}")
 message(STATUS "Lua library: ${LUA_LIBRARY}")
+mark_as_advanced(LUA_INCLUDE_DIR)
+mark_as_advanced(LUA_LIBRARY)