Logo AND Algorithmique Numérique Distribuée

Public GIT Repository
xbt_config: kill an unused feature: unregistering variables
[simgrid.git] / README.lua
1 SimGrid requires Lua 5.3; it will not work with Lua 5.2 or Lua 5.1,
2 as Lua 5.3 breaks backwards compatibility. 
3 Version 5.3.2, 5.3.3 or any 5.3.X are ok, though.
4
5 However, installing Lua 5.3 is easy. (If you are an administrator of your machine)
6
7 Step 1: Go to http://www.lua.org/download.html and download the 5.3 package.
8
9 Step 2: Untar the package: tar xvfz lua-5.3.*.tar.gz
10
11 Step 3: cd into the new directory
12
13 Step 4: Apply the patch in "<simgrid-source-dir>/tool/lualib.patch" to the
14         lua source:
15
16         For instance, if you unpacked the lua sourcecode to /tmp/lua-5.3.1, use
17         the following commands:
18
19         cp tools/lualib.patch /tmp/lua-5.3.1
20         cd /tmp/lua-5.3.1/
21         patch -p1 < lualib.patch
22
23 Step 5: make linux
24
25 Step 6: sudo make install
26
27 Step 7: Go back to the SimGrid source, and run ccmake again. Try removing CMakeCache.txt if it still complains about Lua being not found.